Word from Anet on the last security update

  • New Link: https://wiki.guildwars.com/wik…Lo_Presti/News/2018-06-08


    Hi everyone,

    • Some players may be experiencing network issues while trying to login to Guild Wars, as they may have authentication set up on their account and it locked them out of the game. If you’re affected by this, we added in yesterday’s last update a modal dialog to enter the two factor authentication code for your login session. You can also try to authorize your network the following way:
    • Check the e-mail to your registered address, or an SMS, or a security code on your mobile authentication app. You should have received an authentication code that needs to be confirmed at https://account.arena.net/security/settings
      As you attempt to log into the website, you will find the system requesting you confirm your log-in. Please use the most recent code you received. Once you’re logged in, confirm your network there. You will then be able to log into the game
      Please also note that you will need to follow these steps each time you attempt to login from a new network address
    • If none of those solutions work for you, please contact our Customer Support at https://help.guildwars2.com Provide as much information as you can so that agents can process your request as efficiently as possible.

    --Stephane Lo Presti talk 21:12, 8 June 2018 (UTC)

    Doing a full Prophecies play through with all human team. Mon, Thu, Fri, Sat from 20:00UTC

    Watch at twitch.tv/bsoltan

    Edited once, last by bsoltan ().

  • Before opinions like these " ^ " get into their (dev's) heads and other's "bitchings" as I saw on reddit, I really would love that these muffins/cupcakes get to them asap, so they would know that we support far more updates like these despite any circumstance.


    People go ape when the "sugar rush" of having updates finishes, good lord.

  • It isn't like these dev's are going rogue and will implement these important decisions like 2FA without consulting others. Since they should know it can have a huge impact if something goes wrong.

  • Only way I can log in now is by using the -nosound command line switch.

    Otherwise it either crashes or gives a code 048.

    What a bummer. :(

  • will have to try that command line and see if I can get that far......



    edit: well the -nosound works only if I first right click on the shortcut icon and then click ok (making sure that -nosound is still there)...then I can click on it and it works...on my main computer, and NOT with my old dat file...so am having to redownload (the old way...going to each outpost etc) all of the missing data. On my other computer, nothing is working (guess sp1 is not a good one to have left it at <X) ah well, guess I have something to do for the next few days--and then hope after I redownload all the maps etc that it still works. (It did NOT work with my old dat file, nor my hubbys, it did work with the one I loaded from the old factions cds).

    Really hope they get this fixed!!!

    10305.gifwhere is the 'all you can eat' cookie bar? :cookie:

  • edit....new update. -nosound not working anylonger. I can now get to the log in screen and always get code 048 ...one step forward, 3 steps back.

    I'm sure it's the absolute last thing you'd want to do but have you considered reinstalling the game and using a regular launcher?

  • yep, did just that....took my good ole factions cds and reinstalled from them...got the same error. The only thing that worked (until this last update this morning) was the -nosound and then only without having an old dat file (30,000 files to upload just to get to the loading screen was fun), but it did work ...for a while (would not work with my old dat file nor my hubby's, nor any other command line).

    I could spend yet another night rerereinstalling and see if that makes a difference, however, I think the problem is not on my end as my accounts work just fine on my hubby's computer (win7) so...it has to do with xp and gw and their last update crashing it.

    10305.gifwhere is the 'all you can eat' cookie bar? :cookie:

  • I am sure that it is an issue with xp and gw since the update on the 6th--until then I had NO issues with gw and had not for over a decade, now they push some updates and BAM I can no longer play. They need to resolve this on their end, or change the minimum requirements for gw now (since I believe it has win2000)

    10305.gifwhere is the 'all you can eat' cookie bar? :cookie:

  • I fail to see how they could resolve this on their end. You are using an OS that was launched 20 years ago on 2001, discontinued on 2009 and we are in middle of 2018. Things, especially software related get obselete within weeks nowadays, hardware is even worse, it seems to me you are quite the lucky gal to kept it running without issues for so long.

    Even though I know it sucks and it's heavily frustating since it's probably your main game the rational choice would be totally different. Guild Wars can be run on a toaster nowadays and the most basic to the core computer currently runs windows 10 smoothly and it's onboard video card can run guild wars easily so you don't even need to invest on hardware-end.

    Anyhow, I hope you the best, it really sucks.

  • uh...NO, my computer can NOT run windows 10 (nor will I upgrade to that pile of....)

    The game states the minimum requirements are window 2000, and unless they change that, they need to make sure that someone with that os can play it, now if they want to change their minimum requirements then yes, upgrading is what needs to be done, but as you say this game is 14+ years old---and loads of the code is as well, I dont see them changing things all that much, they just need to fix what they messed up with the last update.



    and here is my proof:


    Quote


    Log-In[edit]


    • Made improvements to help with log-in issues.
    • Fixed a client crash when trying to log in.
    • Added a new error code, 248, for when the game is unable to initialize the log-in system. This is usually the result of an antivirus system or an incompatible operating system. Guild Wars requires that you run Windows XP or later.

    (bold large text and underline...mine)

    10305.gifwhere is the 'all you can eat' cookie bar? :cookie: