GW doesn't start because can't initialise 3D output

  • I play GW on Ubuntu with WINE 7.0

    Since the updated from Ubuntu LTS 21.04 to 22.04, GW tells me it can't start because it can't initialize 3D output. I tried to force DirectX to start but the OS tells me its already running. I don't have an graphic card, I play with the onboard graphic chip of my Intel i5. I can't get any additional driver from the system - I'm probably too early.

    Also I'm not very skilled in Linux. :blush:

    Alliance Battle does not determine who is right — only who is left.

  • Hi, i'm not very good with Linux, but i like to mess with computers in general. Here is what i found under Google:

    Ubuntu 22.04 LTS Disables 3D Acceleration For Guest VMs With GNOME Boxes / Virt-Manager

    Test this (?) ->


    Your graphical issues may be related to the use of Wayland. By default, 22.04 is configured to use Wayland, after a fresh install and even after upgrading, and even on Nvidia cards, where Wayland support is very young.

    You therefore may have better luck running on Xorg for the time being. To switch to Xorg, log out. Before entering the password, select the cog wheel in the bottom right corner and select "Ubuntu on Xorg".

    If you later wish to try Wayland again, do the same but select "Ubuntu" instead.

    Or that, involving the GPU driver integrated in the CPU (?)


    I experienced all of these issues at some point and I think I have figured out the solution. There is something wrong with the 510 version of the NVIDIA driver that is marked as "proprietary, tested" in 22.04 LTS.

    To fix the graphical problems after you load into the game, downgrade your graphics driver to version 470. In Ubuntu, you can do this using the "Additional Drivers" program. After a restart, the problems should go away.

    In any case you are by far the only one to have this problem with version 22.04 ->

    Ubuntu LTS 22.04 3D problem videogames

  • WINE doesn't create a virtual machine. It is sort of an translater. I do not run any kind of VM.

    I did change to Xorg, but it didn't change anything :(

    As I mentioned, I can't find proprioritare drivers in the update / driver-manager. There's just nothing.

    Thank you for the expand of keywords for google, as english isn't my first language. :thumbup: I'm still stuck. :|

    Just found this Thread from 2013:
    It looks suspicious similar to my problem.

    Alliance Battle does not determine who is right — only who is left.

    Edited once, last by Altus: Found an potential solution (August 22, 2022 at 6:02 PM).

  • Wine is indeed not a virtual machine, but uses similar functions.

    If the problem occurred with version 22.04, it is a software problem related to this version. Only a new installation of the old version will prove 100% that this is the case or not. So the 2013 topic is HS and talks about a general graphics problem, not just vis a vis Wine.

    Now i don't know if you have done a "clean install" (installation without data recovery, in a first step, on a blank disk) or a simple update. If you were on Mac OS i could go much further with you, but i don't know how to interpret the system report files of Unbutu.

    I also suck at English, i translate my texts with DeepL and the pages with a web browser extension. But the Unbutu forums, exist in all languages, just find the right one. On these forums, i think some people will be able to interpret your requested system reports and help you with more precision (or eliminate some leads).

    Now to come back to the installation i advise you to follow the steps to install Wine 7.0 correctly, if you have not done a Clean Install and follow tutorial. The problem could come from an obsolete file, which is not up to date or simply installed and which Wine needs as resources. I don't know if you are familiar with sudo commands, but it is not very complicated. Here is a tutorial i found to install Wine 7.0 on Unbutu 22.04 (english) HERE or (french) HERE. I don't know what language you speak.

  • On closer inspection, the 3D output errors are due to a problem with the graphics driver or directX.

    I found someone with the same problem, GW1 + Wine on Linux + output 3D fails, here is what he did:


    I fixed it! Apparently since I am running in 64-bit I had to install some lib32 NVIDIA files. Thanks for all the help anyways though


    Issue was needing to add the 32bit compatibility libraries on his 64bit system

    There must be the equivalent for your intel driver. However, as i don't use Linux, i don't know where to find the installation packages (listing) and you should communicate the exact model of your CPU. Also check that everything is up to date with the latest versions, just to be sure.

    Note: a general computer tip, if you want to be helped more simply on (computer) forums, notify your hardware and the exact versions of software you use. This gives valuable indications, when you want to solve a problem of this nature remotely. The must is a system report file or a terminal report.

  • Update

    The 32bit compatibility librarie got an update, but this didn't solve the issue.

    sudo apt-get install winetricks

    I installed Winetricks and tried some adjustments, but it didn't work. Still no GW at my Ubuntu ?(

    Alliance Battle does not determine who is right — only who is left.