Guild Wars 1 not using graphic card

  • hi


    so my computer can't use my graphic card for GW1, every other games work with my GC
    I tried to force it by using the nvidia panel (by default it should use the GC) and also by right-click gw.exe -> run with processor nvidia high perf' (I think I tried everything through the Nvidia panel) but it still doesn't work as you can see :






    GPU 0 is my integrated graphic and GPU 1 is my graphic card


    any idea please ?

  • hubby says something about gaming profile...perhaps you need to set one of those up? (not a techie person so that is as much help as we can do for you)

    :mouse:where is the 'all you can eat' cookie bar? :cookie:

  • hubby says something about gaming profile...perhaps you need to set one of those up? (not a techie person so that is as much help as we can do for you)

    hmm gaming profile ? I would like a clarification please :p

    Edited once, last by sama ().

  • I found the problem if anyone is interested (my post from reddit) :

    Ok so I actually found the problem :

    • when I play any game with low settings (that's usually what I do because I prefer ultra performance (high fps, no freeze..) over quality, my computer doesn't use the graphic card but the integrated intel graphic
    • but when I put all settings high (and usually fullscreen mode or it doesn't work), the graphic card take over the integrated intel

    For example guild wars 1 : I use to play GW1 windowed+low settings because I'm afk a lot, so the graphic card is not being used. When I put all GW1 settings high AND fullscreen (yeah graphic card still not being used if no fullscreen lol), then the GC works.

    Any idea why ?

  • think my hubby said that when you go to the graphics card interface there is a place where you can specify that it should be used for certain programs (like games). Not sure where it is or how to access it (not a techie, and hubby says it was a very very long time ago he had to do this for his old computer--since rebuilt with new graphics card etc)

    :mouse:where is the 'all you can eat' cookie bar? :cookie:

  • You can disable the integrated GPU by entering your BIOS on startup, you have no need for it when you have a graphics card. How you do it depends on your motherboard. Simply google “name of your mother board” + disable Intel HD graphics. Before you do that though, make sure you actually connected your monitor to your graphics card and not your motherboard.

  • You can disable the integrated GPU by entering your BIOS on startup, you have no need for it when you have a graphics card.

    OP doesn't state if it's a laptop or desktop computer. Both GPUs can be found in desktops and laptops.

    If it's a desktop then yes, disable the integrated GPU in your bios. Laptop is a different as you'd reduce your battery time to 2-3 hours.

  • OP doesn't state if it's a laptop or desktop computer. Both GPUs can be found in desktops and laptops.

    If it's a desktop then yes, disable the integrated GPU in your bios. Laptop is a different as you'd reduce your battery time to 2-3 hours.


    No I can't disable it in BIOS because I don't have this option. It's a laptop, and the monitor goes black for sure if I disable it (through device manager for example?) because the graphic system utilise the iGPU for output (well I'm not sure but since I can't disable it through BIOS, I think I shouldn't).


    But still, is that a normal behavior ? (GC used only when graphic settings are high)

    Edited once, last by sama ().

  • For a laptop, yes it does sound like a normal behavior, probably to reduce heat and extend battery life.



    yup I know but the thing is my laptop temps are fine (never goes more than 60-65 while playing a game) and AC adapter is always plugged in.


    And that's kinda boring because I'm forced to play with high graphics in game settings to use the graphic card :s (and in MMORPG, that sucks because you want to use low settings when a lot of people are around but if I do that, the graphic card won't be used :/ happened to me for the Bless Online Early Access 2 days ago, and I had 10-40FPS top - and the .ini fix didn't change anything - so I refunded the game lol).

  • Do you use Windows 10? Perhaps you can try this (assuming English version):


    1. Press Win-key, type/select "Graphics Settings".

    2. Choose classic app, click browse.

    3. Browse for your GW.exe file, click add.

    4. Click the icon that now appeared and select options.

    5. Change to High Performance.

  • I've done that already just after the last w10 update dw but nothing changed

    The problem doesn't come from my settings (windows/nvidia) but from the computer/intel, that's the way it works and I can't change anything :(


    I'm just forced to play any games with high quality settings and fullscreen.