In-Game Connection Issues

  • Hello everyone and thank you for your time.

    I'm an old GW player coming back after a couple of years to the game to help a friend getting 50/50 on his HoM to unlock the rewards on GW2.

    I'm very happy to come back to one of my favourite games, but since I tried to play I ran into a very annoying issue: frequently when I try to change map (be it transitioning from an area to another or simply fast traveling to an Outpost) the game gets stuck in a loading screen which says "Connecting" and shows a loading bar that won't go above 0%. The only thing I can do in this case is closing the game and re-enter, but makes the game a pain to be played, and also will prevent me to do things like dungeons or caravan vanquish of high level areas.

    Is there any way to solve this problem? I've already sent a ticket to the Support, but didn't yet received an answer. I've read on the internet that there was some problem with the servers in Frankfurt, is it because of that that I'm encountering this issue?

    Thank you in advance for your answers.


    Today I created a new character on Factions and have been able to play non-stop for four hours without encountering any connection problem. Then I closed the game and went on doing other things. When I tried to play the game again I couldn't even go outside Shing Jea Monastery that the issue reappeared, forcing me to close the game. What does this mean? New characters are immune to the connectivity issue? I really don't know, but wrote another mail to the Support to let them know my experience, hoping it will help them help me.

  • Ditto, several occurrences over the last couple days. Kept thinking my Wi-Fi dropped but turned out to only be in-game.

    My Legacy Posts: WTSell | WTBuy

    Definition of "Collection": An Accumulation of objects gathered for study, comparison, or exhibition or as a hobby.

    Note: Definition does not specify rarity or value, although it could be a choice, it's not a requirement.