High lag and rubber-banding

  • So I recently bought Gw1 and played it because i wanted to know more of the lore and stuff.

    I started the game, had no problems with login or character creation.

    After a while ingame i started to have weird lags and when i wanted moved my character he would just

    stand still and after a short period he would teleported away just to stand there again and wait.

    likewise I cant talk to NPC's take on quests or sell anything.

    So i searched for any resolutions and found out that people have/had the same issue.

    I did download the whole game by using the -image command, i fixed my fps with v-sync

    and i dont Alt-tab. (i dont do this anyway)

    I really want to continue playing the game but under this conditions its just not fun.

    If there is anybody out there who could help me with my problem, i would appreciate your help.

    God bless you.

  • I live in Germany so i use the European server. what exactly im on i dont know, I cant see any server options other then this district thing where im on

    European-English district 1. I tried to change the District to European-German district but that doesnt seem to change anything.

    I dont have any issues with other games.

    thanks for the effort!

  • I know they had issues with the european server a while back, try changing to the american (USA) server and see if you have the same issues---most people are now playing on that one. If the problem still persists, perhaps someone more technically talented (I am not) will jump in.

    :mouse:where is the 'all you can eat' cookie bar? :cookie:

  • Are you sure your fps is actually locked? Check the green dot in the bottom right corner. The v-sync option doesn’t seem to work for me. I have to lock it by using the -fps command. That fixed all my rubberbandibg issues!

  • I tried to change the server like you said and it actually is better but still not really playable its still lagging like sh*t. I guess that is because of the latency.

    And yes im sure i set it on V-sync, always 60 frames atm.

  • I say it again i dont have any problems with other games, its not my computer or neither my internet connection.

    I played the game for 4 hours on saturday without any problems, so thats not it.

    Normally i have about 16ms up to 3k but i cant explain why, i play Guild wars 2 and watch a video at the same time and there are no problems.

  • Sounds like an intermediate node is dropping packets.

    Check the IP of the server you're connecting to on a loading screen.

    Open a command prompt and run "pathping {that IP}".

    Post here. (For privacy, blank out the IP addresses for hops 0 and 1. If you connect to the internet via a router, also blank out the IP addressess for hops 2 and 3.)

  • I tried that but somehow it doesnt work, when i put the command in it just says the target system couldnt dessolve. you want me to put the IP-address in here which im connection to, like for example what do i have to blank out? I dont know what you mean by hops xD

  • I tried that but somehow it doesnt work, when i put the command in it just says the target system couldnt dessolve.

    Let's try this again with more detail:

    Step 1: Find out the IP for the server you're having problems with. You can see the IP in the top left of the loading screen as you enter a zone, and also by mousing over the ping dot. For example, the IP of Kaineng Center American 1 is

    Step 2: Open up a Windows command prompt.

    Step 3: Enter the command

    1. pathping {that IP}

    into the command prompt. To be clear, you need to replace {that IP} with the IP of the server. So, for example, if you were having trouble when visiting Kaineng Center American 1, then you'd use

    1. pathping

    (Also, ignore the "1. |" at the start of the line. That's just a line number that GWLegacy's forums software added.)

    Step 4: Copy/paste the output of the command to a text editor (e.g., Notepad). (Note: The copy/paste implementation in the Windows command prompt sucks butt. If you can't figure it out, see here for an explanation.)

    Step 5: Blank out the IP addresses that may reveal private information about you or your local network configuration. Here is a screenshot of some pathping output. In it, you can see that first there is a list of all the hops from you to the target server, and then there is the same list with statistics for each hop. Blank out the IP addresses in the lines for hop 0 and hop 1. (In this example screenshot, they are and, respectively.) Just type over them with XXX.XXX.XXX.XXX or something. Remember that each hop appears in two lines -- you have to blank it out in both the top and bottom lists. If you have a router, then also blank out the IP addresses in the lines for hop 2 and hop 3. (In this example screenshot, they are and, respectively.)

    (Note: This is a "quick and dirty" explanation that probably blanks out more than necessary. I'm not attempting a full explanation because anyone with enough background knowledge to understand it can probably already read a pathping.)

    Step 6: Post the redacted results here.

    Edited once, last by Chthon ().

  • Ok heres the result:

    Routenverfolgung zu "ec2-18-194-211-179.eu-central-1.compute.amazonaws.com" []

    über maximal 30 Hops:

    0 Someones-PC.fritz.box [XXX.XXX.XXX.XXX]


    2 * loopback1.92.brun.0035-04.fra.de.net.telefonica.de [XXX.XXX.XXX.XXX]

    3 bundle-ether30.0001.dbrx.02.fra.de.net.telefonica.de [XXX.XXX.XXX.XXX]

    4 ae5-0.0001.prrx.11.fra.de.net.telefonica.de []

    5 ecix-fra50.amazon.com []




    9 * * *

    Berechnung der Statistiken dauert ca. 200 Sekunden...

    Quelle zum Abs. Knoten/Verbindung

    Abs. Zeit Verl./Ges.= % Verl./Ges.= % Adresse

    0 SomeOnes-PC.fritz.box [XXX.XXX.XXX.XXX]

    16/ 100 = 16% |

    1 26ms 25/ 100 = 25% 9/ 100 = 9% FRITZ-NAS [XXX.XXX.XXX.XXX]

    0/ 100 = 0% |

    2 13ms 16/ 100 = 16% 0/ 100 = 0% loopback1.92.brun.0035-04.fra.de.net.telefonica.de [XXX.XXX.XXX.XXX]

    1/ 100 = 1% |

    3 13ms 23/ 100 = 23% 6/ 100 = 6% bundle-ether30.0001.dbrx.02.fra.de.net.telefonica.de [XXX.XXX.XXX.XXX]

    0/ 100 = 0% |

    4 14ms 17/ 100 = 17% 0/ 100 = 0% ae5-0.0001.prrx.11.fra.de.net.telefonica.de []

    83/ 100 = 83% |

    5 --- 100/ 100 =100% 0/ 100 = 0% ecix-fra50.amazon.com []

    0/ 100 = 0% |

    6 --- 100/ 100 =100% 0/ 100 = 0%

    0/ 100 = 0% |

    7 --- 100/ 100 =100% 0/ 100 = 0%

    0/ 100 = 0% |

    8 --- 100/ 100 =100% 0/ 100 = 0%

    Ablaufverfolgung beendet.

  • OK, looks like you have two problems here. Either one is bad enough to independently ruin your gaming experience. And I'm sorry to say that only one of them is something you can fix. I'll start with that one.

    Problem 1: The connection from your PC to your router is over 25 times slower than it ought to be, and you've got 25% (!!!!) packet loss. I could stick an ethernet cable into a potato and get a better connection. My best guess here is that you're connecting to your router over wifi, and suffering terrible interference. (If this is a hard-wired connection, then something is very, very wrong with your router, your PC, or both...) You have two possible solutions: (1) The easiest and best solution is to simply plug in a physical ethernet cable. Problem solved. (2) The other solution is to use some software to scan for the frequencies and strengths of nearby wifi signals, then change your router's channel to a less crowded frequency. Unfortunately, this may not even be possible in some densely populated urban areas, since there may be so many routers nearby that there is no uncrowded frequency. (You could also try to call a neighborhood meeting to organize everyone's wifi frequency usage into the optimal configuration given their spacial positioning, but my experience has been that neighbors are generally too stupid to make this work, and a few non-participants make the whole thing impossible.)

    Problem 2: There's 83% packet loss between telefonica.de's and amazon's Judging from the node names and a reverse IP lookup, it looks like something's wrong at a peering exchange probably in Frankfurt. You can't fix this, since it's not on your end. And A-Net can't fix it, since it's not on their end either. You'll have to wait for telefonica.de and/or amazon to fix it. If it's a hardware problem, hopefully these companies will sort it out soon. If it's a temporary too-much-volume problem, you'll just have to wait for it to subside. If it's a chronic too-much-volume problem, maybe someday the company at fault will decide to upgrade to higher capacity hardware.

    (Aside: To help you understand why packet loss is such a problem for online games: If you click on a position in the game client, your client sends a message off to the server saying, "I want to move my character to position X,Y." Well, if that message doesn't make it to your router, then it's not going to make it to the server either. So, if you've got 25% packet loss at your router, then the server will never hear 25% of your attempted commands. Your client thinks you're moving, attacking, using skills, whatever, but the server never hears it. Since the server's view of the game world is authoritative, these actions never happen. Your client may preemptively animate them to keep things smooth, but then it has to roll them back when the expected confirmation from the server doesn't come -- that's "rubberbanding." Going the other direction, the server sends your client update about the state of the game world -- your character is at position X,Y; now your character is at position X+1, Y; now your character is at position X+2, Y-1; etc. If 25% of those messages die at your router, then your computer doesn't seem them. The result is a herky-jerky view of the world where things teleport around without appearing the cross the space in between. All of this is ameliorated to the degree it can be by making the client and server smart enough to deduce when a message hasn't gone through and to resend it, but that deduction is slow, since it requires a response from the other side or a timeout to elapse -- so, even if a dropped message gets resent, the resulting experience is still really laggy. The bottom line is that packet loss is the absolute bane of online games.

    You might be wondering why you don't notice these problems when streaming video or browsing the web. Packet loss effects these, but not nearly as badly as it effects online games. Videos are streamed with a buffer of several seconds. So long as a dropped packet can be resent before the buffer runs out, you never even notice it. Resending dropped packets causes webpages to load more slowly, but usually not beyond the threshhold where you take notice. But games require the illusion of real-time interaction, so the delay imposed by a resend is very noticeable.)

    Edited once, last by Chthon: [edit: I misread the timing on the first hop. It's only ~25x slower than it should be, not ~125x.] ().

  • I see, so my Internet could be way faster if there wouldnt be the package loss. In the past we had couple problems with our Internet which caused it to just top for weeks and our Internet providers in Germany are to dumb to fix it. I dont have a clue whats wrong with it here.

    Now have two things i dont understand, i tried to play the game every day in the week since Saturday last weekend and yesterday i had literally no problems, ok a little lag here and there but i didnt even recognized it, i couls play smoothly the whole day.

    The other thing is, i have a physical cable from my computer to my router

    I call it "lan-cable" is that the same as a ethernet cable or is that different?

    Thank you for your help, i appreciate it!

  • The other thing is, i have a physical cable from my computer to my router

    I call it "lan-cable" is that the same as a ethernet cable or is that different?

    Yep. It's the same cable. That means that something is horribly, horribly wrong with your PC, your router, another device on the network, or some combination thereof. There are a million different things it could be. I don't have time right now, but I'll try to write up a diagnostic plan for the most common ones in the next few days.


    i tried to play the game every day in the week since Saturday last weekend and yesterday i had literally no problems, ok a little lag here and there but i didnt even recognized it, i couls play smoothly the whole day.

    My guess is that the problem in Frankfurt was (temporarily?) resolved. Going from net 87% packet loss down to only 25% packet loss ought to feel like a huge improvement. Now, 25% loss is still really bad -- most people would consider it unplayable -- so hopefully we can get the problems on your end fixed so you can experience 0%.

  • Alright, let's do this.

    General Note #1: In this post, I'm ONLY trying to help troubleshoot the local problem with your PC, router, and/or other network devices. There's nothing you can do about the problem in Frankfurt, so I'm not even going to mention it again in this post.

    General Note #2: My main goal here is to rule out some possibilities to narrow down the source of the problem. We'll likely have to go round again with more detailed troubleshooting once we've got a better idea where the problem is.

    General Note #3: We need a procedure for consistent experiments. Here's that procedure:

    1. Run a pathping to verify that the problem still exists at the time you are starting the experiment.
    2. Try one of the experiments listed below.
    3. Run another pathping to see if the problem persists.
    4. Go back to #1.

    General Note #4: I think I need to describe what a good pathping versus a bad pathping looks like. Look at the example from my earlier post. Note the following four values:

    • The RTT for hop 1 is "0ms." (Really probably around 0.3, rounded down to zero.) 1ms would be a bit slow, but I guess maybe within the range of normal if you have a shitty router. Anything slower than 1ms definitely indicates a problem.
    • The "This Node/Link" lost value for the line between hops 0 and 1 is 0%. Any loss whatsoever here indicates a problem.
    • The "Source to Here" lost value for the hop 1 line is 0%. Any loss whatsoever here indicates a problem.
    • The "This Node/Link" lost value for the hop 1 line is 0%. Any loss whatsoever here indicates a problem.

    If all of the four values above are OK, then your local network is likely free of connectivity problems. If one or more of the four values above is bad, then you've got a problem on your local network.

    Experiment #0: Reboot

    Give the router a hard reboot. Disconnect it from power for 5 minutes, then turn it back on.

    Experiment #1: Maybe the ethernet cable is loose.

    Unplug both ends, then replug them.

    Experiment #2: Maybe the ethernet cable is damaged.

    Unplug the ethernet cable and replace it with a different cable.

    Experiment #3: Stop All Torrents/Streaming

    Ask everyone in your household to (temporarily) stop all torrent/streaming activities.

    (Note: The default configuration on most torrent clients should prevent it from getting anywhere close to saturating a router. The only way this should be a problem is if someone turned off the limits on bandwidth and/or concurrent connections.)

    Experiment #4: Rule Out Your PC

    Recruit a friend with a laptop.

    Have your friend verify that they have an OK pathping (see above) using a wired connection to their router at their home.

    Have your friend bring their laptop to your home.

    Unplug your PC and plug in their laptop using the same cable.

    Experiment #5a: Rule Out Other Devices

    Disconnect all other devices besides your PC from the router.

    Note that you may have a lot of things besides computers connected to the router.

    You might have:

    • Smartphones connected to wifi
    • Video game systems (e.g., XBox, Playstation)
    • E-book readers (e.g., Kindle)
    • Televisions
    • IOT crap like Amazon Echo, security cameras, "smart" thermostats, "smart" lightbulbs, "smart" this, "smart" that, etc.

    To make sure that you've disconnected everything, you must log in to your router's administrative panel and make sure that the list of connected devices contains only one entry for your PC.

    (At this point, you might find neighbors leeching off your wireless. If so, change the password.)

    Experiment #5b: Rule Out Other Devices One-at-a-Time

    If Experiment #5a eliminated the problem, then try #5b. Otherwise, skip #5b.

    Try reconnecting the other devices one-at-a-time to determine which one is the source of the problem.

    Follow these steps:

    1. Reconnect a device.
    2. Wait about 5 minutes.
    3. Try a pathping.
      1. If the pathping goes bad, you know that this device has a problem. Remove it again before continuing.
      2. If the pathping does not go bad, then this device is not causing a problem. You can leave it connected.
    4. Go back to #1.

    Hopefully this should gives us some clue where the problem is located.

  • Hey, sorry for not answering.

    i was a bit busy at the weekend.

    I will try to do the experiments but i think i cant do all of them and also not now.

    Like mentioned above im a bit busy lately and thats why im not at my computer atm.

    There is still one thing i want to say, I set the game in windowed mode,

    do you think that helped getting rid of the bad connection?

    I would say no because what does the window-mode have to do with the connection.

    But im still curious.

    Anyway thank you for your help!

  • No. Graphical issues are completely independent from network connectivity issues.

    There is a known bug with Guild Wars where running with a high frame rate causes lag and rubberbanding.

    You can try to enable Vertical Sync, that might limit the frames enough to stop this from occuring.

    Hi there! I'm the Guild Wars Legacy admin, feel free to contact me if you've got issues.

    :ass: Inquisitor Karinda :der: Sunspear Elke :mes:Librarian Amber